Staking amount does not show up in my MetaMask

Good morning, this morning (Jan-18-2022 08:03:48 AM +UTC) I have tried to stake my Time amount but it does not show up as MEMO in my metamask. Also the amount of Time is still the same.
When I look at the , I see that the stake transaction is Success full. AVAX Transaction Hash (Txhash) Details | SnowTrace
When in connect with my metamask to Wonderland I don’t see any staked MEMO and the amount of Time is still the same.

When I try to stake again, I am getting an error message:

{"code":-32603,"message":"Internal JSON-RPC error.","data":{"code":-32000,"message":"execution reverted"},"stack":"{\n \"code\": -32603,\n \"message\": \"Internal JSON-RPC error.\",\n \"data\": {\n \"code\": -32000,\n \"message\": \"execution reverted\"\n },\n \"stack\": \"Error: Internal JSON-RPC error.\\n at new i (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:148782)\\n at s (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:146325)\\n at Object.internal (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:146935)\\n at u (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:95847)\\n at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:96879\\n at async chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:12923\"\n}\n at new i (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:148782)\n at s (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:146325)\n at Object.internal (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/common-0.js:18:146935)\n at u (chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:95847)\n at chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:96879\n at async chrome-extension://nkbihfbeogaeaoehlefnkodbefgpgknn/background-1.js:1:12923"}

Can you please help?
Best regards,

You need more AVAX for gas fee most likely. 0.1 is recommended, but it does not cost that much.

oke, check, but why is the transaction successful in the blockchain, when you look at snowtrace (AVAX Transaction Hash (Txhash) Details | SnowTrace)

Ah. Staking is a two step process (same with wrapping, unwrapping an unstaking) the first time you do it.

First you APPROVE, which is the transaction that went through, then its recommended to refresh the website and then you can STAKE.

If you look at “Transaction Action” it says approved, which means you did not stake yet.
This is a DeFi standard pretty much, but it is not really clear when you do this for the first time.


aha, oke that is clear. So if I start the staking process again with enough avax in my wallet it will go through, right? Or do I need to do something else now that the first part was succesful?

It should yes :slight_smile:

Could always have other errors, based on other issues, but normally, that would be all you need to do yes.

1 Like

thank you so much for your help!
Somebody else wanted to “help” me before you replied and asked for my MetaMask 12 word phrase… f*ckers.

1 Like

report them in:

1 Like

I have posted my warning. Thanks again!

1 Like