Trouble staking for the first time

On the app, when I hit the stake button, I confirmed it through metamask and it was pending for a few seconds, and then approved and the little green sliding bar popped up and said “Your transaction was successfully sent” . The transaction does show up in MetaMask wallet as approved, as well as in snowtrace, However none of the values on the Wonderland page changed .In other words, I’m still seeing: Your Balance: 0.4426 TIME , Your staked Balance: 0 MEMO , Wrapped Balance: 0 WMEMO , Next Reward Amount: 0 MEMO , etc… ) . I have 0.0967 AVAX currently in MetaMask, which seems more than plenty to cover gas fee costs. I do see the TIME and AVAX assets in MetaMask (under the Avalanche MainNet) , and those numbers have not changed.
After waiting a few minutes re-tried the same steps, but still no numbers changed. Tried disconnecting and reconnecting from the App, and also waited 20+ hours, but no changes were seen in the Web app page. I have enough funds on the MetaMask AVAX to cover the gas fees.

the first transaction is a contract approval, the second one should let you actually stake and convert your time into memo, be sure to select max and then stake (and ofc approve the transaction)

1 Like